Follow

What are the browser, system, and/or network requirements to use Vendor Management?

Vendor Management from CBANC is a web-based data-driven application that utilizes some of the latest technologies in terms of both features & security to optimize the user experience.  We recommend using the latest version including security update & hotfixes of Internet Explorer, Chrome, Safari, or Firefox.  

Having said that, the minimum browser & system requirements we support are:

Browser: IE10+, Chrome 30+, Safari 6.2.7, Firefox 38*

OS:  Windows 7 SP1, Mac OS X Mountain Lion v10.8.5

Network Connection: 1Mbps or Greater

 

IMPORTANT TO NOTE: As web security is a constantly evolving discipline, please be sure to stay up to today with the latest technical security notifications & hotfixes for your specific browser & version:

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk